assuming this is completely unavoidable:
of the options, i'd use
preventWindowFromJumpingWhenKeyboardAppears; also detailing the issue in the method's documentation (what versions it is known to appear, how to repro, or a case #).
if you are introducing something awkward, it's best to make that obvious, to detail the motivation/issue, and to quarantine the workaround. otherwise, people read it and get confused (or omit its use if they have not spent a lot of time with your interfaces). then they may remove it in the future because they are not sure why it exists ("... but it tested fine on the latest OS."). for really bad cases, i'll use even more syntactic stigma because the method name you have chosen does not stand out when scanned.
if you can keep it entirely within private implementation, even better.
preventWindowFromJumpingWhenKeyboardAppears makes it pretty obvious at the call site that there is a legitimate bug as well as the context it pertains to, rather than some haphazard implementation.
forceSpecifiedWindowPosition makes little sense in comparison.