Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

What I'm trying to do? I'm using gVim on Windows, and am trying to get something that looks like this.

alt text

See the indent lines and tab characters? (check out the link for the big picture if this one is too small)

I tried a lot of things already, some of them having to do with fonts, some of them having to do with encodings, some of them having to do (it seems) with the current air pressure, and wind speed. But none of them worked.

share|improve this question

closed as off topic by Yannis Rizos Aug 20 '12 at 6:47

Questions on Programmers Stack Exchange are expected to relate to software development within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If you have a question about whether something is appropriate for this site, ask it on the meta-discussion site. –  user8 Oct 21 '10 at 7:30

1 Answer 1

I don't know if I'm not 100% clear, but if you're talking about seeing hidden characters and :set list doesn't cut it for you there's an entry on SO to tweak it further: http://stackoverflow.com/questions/1675688/make-vim-show-all-white-spaces-as-a-character

EDIT: OK, try this one out, then:

:set listchars=eol:$,tab:\|-,trail:~,extends:>,precedes:<

And then type :set list and see if it matches what you're looking for.

EDIT: Hmmm - I dug a little more and found this info http://www.mail-archive.com/vim@vim.org/msg09289.html

vim is currently unable to display glyphs for Unicode supplementary chars (they appear as question marks)

The post is several years old, and I'm running GVim under Windows 7, but I get the question mark whenever I try to put in supplementary characters.

Now I am eager for a vim ninja to come along and show me the way, also :-)

EDIT: Last stab, and then that's enough time down this rabbit hole.

:set listchars=eol:$,tab:\|\¬,trail:~,extends:>,precedes:<

To get the funny glyph after the escaped pipe character (under Windows) type CTRL+Q then CAPITAL U then 00AC and then hit enter (props to Rook for the link). It's not EXACTLY what you wanted, but it is a character you won't normally type and it will display in a contrasting color under Windows.

share|improve this answer
    
No, no ... you're right on track. I was^ talking about seeing hidden characters. However, I would like them to have a little esthetics - so I was asking how to get particular unicode characters to show instead of a tab character. In the above example (picture), those are a vertical line, which indicates where a tab character "started", and little dots which indicates "how far it went". I was unable to replicate that behaviour - therefore my question. –  Rook Oct 20 '10 at 16:57
    
Hi, yes, that's pretty much what I'm using now. But (there is always a but ;-), the "|" character is intermittent, and "-" character is often used for something else. That's the beauty of unicode chars. - they're rarely used in code for other purposes. For example, unicode box drawing characters, table 2500: utf8-chartable.de/unicode-utf8-table.pl?start=9472&names=- givin' you +1 for the effort for staying on the topic though. –  Rook Oct 20 '10 at 17:36
    
Another nice example here vimcasts.org/episodes/show-invisibles (search for listchars) –  Rook Oct 20 '10 at 17:40
    
(comment on edit): Some of those issues were dealt with in Vim version 7.3 (relatively new). As far as [?] character, that varies. Try setting your "set encoding=utf-8" to or some other value. True, not many fonts still have those characters, but it is not a vim issue anymore. –  Rook Oct 20 '10 at 19:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.