I have a method that checks a database to make sure that it contains all the necessary schemas for a given version of the application to function. There are many versions in the wild. If the database contains out of date schemas or none at all then the method creates/updates the database to the latest state and returns true.
What could I call this method? I know this is a subjective question, but I feel like there is a proper term that can convey the behavior of this method without being too verbose like verifyAndUpateAppSchemas or buildMissingSchemaAssets. Thanks.