Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

I've been wanting to try out VS2011 and .NET 4.5 beta, but the upgrade path is confusing at best. If I understand what I've read, the .NET 4.5 framework overwrites the .NET 4.0 libraries on your local machine, so libraries such as mscorlib.dll and System.dll will be replaced with the 4.5 version - fully backward compatible, but still different.

If I'm developing ASP.NET sites with VS2011, and assuming I don't use any of the new 4.5 features in the code, do you know of any issues I might have by deploying to a web server with only the .NET 4.0 framework? I wouldn't expect any problems since it's the same CLR, but I'd like to know for sure before I do it.

There's always the option of keeping a separate virtual dev machine for 2011/4.5 so that I can develop on 4.5, but go back to my original 4.0 machine to compile and publish, but I'd rather not go that route if I don't have to.

Thanks

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It's true, but not an issue. Looking in the frameworks directory where you have one directory per version, there isn't one for 4.5. However, I have VS2010 and VS11 on this machine and they coexist happily.

When you start VS11 you can pick 4.0 or 4.5 from the list of target frameworks. VS2010 of course still only targets 4.0. *(of course you can pick 3.5 and 2 too).

As for deployment it isn't an issue. I've deployed to machines with just 4.0 installed and it just works as you'd expect. I haven't deployed any 4.5 code yet though.

share|improve this answer
4  
The biggest problem you'll have is getting used to the hateful gray on gray colour scheme >_< –  Ian May 6 '12 at 6:28
    
Awesome, thanks for the info. I'm not planning on deploying any 4.5 anytime soon, so I'm not too worried about that. And I'm with you 100% on the VS design - absolutely atrocious. –  Joe Enos May 6 '12 at 6:55

It's not 100% backward compatible. Installing 4.5 will prevent StructureMap from working even on a 4.0 project. See this Connect issue for details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.