Surely it'd make more sense for the name to be one of the following:
- xmlHttpRequest (camelCase, also common though not for classes)
- XMLHTTPRequest (caps-for-acronyms, rarely used in programming?)
I'm sure there must be some reason and I'd hate to think it's now set in stone just because no one questioned this at the time. Is there another naming convention that I'm unaware of?
XMLHttpRequest specification: http://www.w3.org/TR/XMLHttpRequest/