Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

I've been making small improvements to a public ASP.NET site that I have and have ran it through Google's online Page Speed several times. I have a specific problem, but something that really threw me off was that even if I didn't make any changes and just kept running it time after time (5 minutes intervals) I'd keep getting different scores by +-1 or 2 points. That is just weird in itself. Anyways,

The only medium priority item that I have left is that PageSpeed says that some of the images do not have an expiration date (or have the expiration date in a very near feature), which I cannot see how it's possible, since they are static resources (images), and I setup the expires to 60 days after the initial request. It's not even a week from now, and they are in the exact same location that the rest of my images are (and about 95% of them are not being marked as not having an expiration date)

So, how could it be that for Page SPeed, some of my images have an expiration date and others dont?

I also ran HttpWatch against my site, and I analyze the specific request of one of those images, and it does have the max-age=5184000 header.

any ideas are greatly appreciated. Thanks.

share|improve this question
    
do you also use use Chrome tools in your page speed and rendering optimization? –  Yusubov Jul 21 '12 at 15:23
    
not right now...but what does that have to do with the specific issue at hand? –  silverCORE Jul 21 '12 at 15:30
    
i just proposed a simple suggestion to look at it, which should simplify and empower your optimization routine. –  Yusubov Jul 21 '12 at 16:46
    
thakns ElYusubov, I do use Firebug and other optimization tools...but I need an answer for this specific problem. –  silverCORE Jul 21 '12 at 16:59
add comment

1 Answer

up vote 0 down vote accepted

Google ain't perfect, humans make mistakes, maybe you found a bug on Google Page Speed Insights or maybe you didn't.

Page speed's score is not consistent and yes it will be -1 or +1 of what you got from time to time. I think some of the reasons are some of the compression algos it uses and whatnot change slightly when telling how much savings can be had on image/css/js compression. Also cookie headers are different sizes from one request to another. Sometimes if you have 3rd party scripts they can alter the code slightly and give different results. Then there's network latency and other factors like TTFB. Run your tests on http://webpagetest.org using the 10 max test runs from various locations (dules, miami, new york, etc) to gather more data. It also gives you a page speed score. You can also use http://www.showslow.com/ and signup and submit your url for daily tests.

Basically find out what other tools say about your image caching headers. 60 days should be fine but maybe they are not setup right?

Run some of your image urls through http://redbot.org/ it gives some nice recomendations and you might have incorrect headers. A lot of places advise a format that is not standard and in fact are incorrect date formats.

I probably said this tons in other answers but this tutorial really helped me a lot and it's a good read for anyone interested in understanding web caches: http://www.mnot.net/cache_docs/

Other testing sites

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.