I think this is the right stack for this.
I have a helper class which builds CAML queries (SharePoint XML for getting list items from SQL)
There is one method that is flexibly used to build the queries that get all related votes and comments for a social item.
I don't want to call it BuildVoteorCommentXML or something long winded like that. Is there a good naming convention for getting all Join/Foreign Key objects from a core object?