Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

I have an open source project that works on .Net 2.0 and up. The thing is though that I prefer to use Visual Studio 2012, which forces the solution and project files to only work with VS2010/2012.

What exactly should I do? I don't want for my users to have to create a solution from scratch if they don't have access to VS2010, but yet, I also don't want to attempt to keep 3 different project files in sync(VS2005, VS2008, and VS2010/2012)

What is the usual solution for this?

share|improve this question

1 Answer 1

What is the usual solution for this?

Try to split your source project to versions. (v1.0- VS08 , v2.0 - VS12). You may still keep .NET 2.0 compatible code with VS2008, and name it as version v1.0, while having your next version be compatible with .NET 5.0 framework and named as v3.0.

share|improve this answer
    
Not sure if this answers the question as I understand it. I think @Earlz is asking how to keep the solution file unlinked from the version of IDE he's using. –  user2039 Sep 16 '12 at 17:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.