Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

What policy do developers have when it comes to supporting earlier versions of Android? I still support , but this means that I am unable to use features such as the action bar. Over 40% of my users are still running versions below 3.0, so I feel somewhat constrained about this.

The problem is that 3.x was not very successful, so 2.3.x will be with us for some time. But all new devices will now be shipping with 4.x. I am wondering whether 4.x users are more likely to pay for an app, while most 2.3.x users are just looking.

Update: With a little effort, I have found that I am able to implement action bars and Holo themes, and still support Android 2.1. All this without recourse to an external library. The only feature that I am still stuck with is tab bars. These do work with action bars, but not in the approved style. For that I would need fragments, which requires Android 3.0. I only have two tab bars though, so it is not a big deal.

share|improve this question
2  
3.x was for tablets only, but since Android has been way more successful on smartphones until recently, don't expect too many 3.x devices on the wild. –  user281377 Oct 31 '12 at 8:39
2  
Just have two versions of the application. You can't support everyone, and those that are running a version after 4.x, they likely won't use an application that used 2.1 interfaces. –  Ramhound Oct 31 '12 at 11:26
add comment

2 Answers

I had the same problem you did. I wanted to support as many versions as possible in my application.

After a while I figured out I couldn't use all the cool things Android 4 had to offer me so I had to go up a minSDKVersion (and again, and again).

now I'm stuck at 2.3.3 with what I'm rather happy, looking at the distibution of versions: Current Version Distribution

Looking at that you'll target a great number of people if you set your minSDKVersion to 2.3.3.

Regarding your problems with Action Bars which you can't use, have you looked into ActionBarSherlock

share|improve this answer
    
I could switch to 2.3.3, but I would not gain very much. I have looked at ActionBarSherlock, but I am reluctant to use that sort of solution. –  Philip Sheard Oct 31 '12 at 8:35
    
Yes API 9 is the min sdk version in our product, it is a good compromise –  Kemoda Oct 31 '12 at 8:45
1  
@PhilipSheard Why are you reluctant to use such a solution? from my point of view it's the only solution if you want the ActionBar on Android 2.x. –  SterAllures Oct 31 '12 at 9:13
add comment

With our app we still support Android back to Version 2.1, but are able to use all the important features of Android 4.0 using the following two components:

These two components are both free to use and enable you to use the newly introduced concepts like ActionBar and Fragments in a very easy way. The frameworks make all the work for you to make your app look and run the same on a pre 3.0 and on a 4.0 device! As you have 40% users pre 3.0, it surely is a good idea to make your app available for them. Splitting the apps for pre 3.0 users and 3.0+ users is in my opinion not a good solution, as you have more work to do to maintain both versions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.