Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with Visual Studio 2012 and Environment Variables under Windows 7. I added a variable called {LIBS} with the value C:/libs/. In C:/libs/ are folders containing C++ libraries.

So far, so good. I added the paths to the project's settings (linker etc.), like {$LIBS}boost to include the boost libraries.

I expected that I would now be able to use something like this

#include "boost/someboostfile"

but this does not work, I have to use the absolute path

#include "../../boost/someboostfile

but this is what I do not want to do.

Is there anything I'm doing wrong?

share|improve this question
up vote 4 down vote accepted

Use angle brackets- #include <boost/someboostfile>.

share|improve this answer
This just works fine - thank you! – verbose-mode Feb 10 '13 at 21:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.