I am using a lot of DateTimes in my application. Now I usually name it like StartDateTime, EndDateTime, etc, to imply there is also a time involved.
I am getting a bit tired of this (it is tiresome to read), and most of the time it is quite logical there is a time compartment to it anyway.
Now I'm thinking about ditching
StartDateTime in favor of the shorter
StartDate, despite that there is also a time part included.
What is better: easier to read vs being more explicit about that there is a time included?
(ps: I guess this has a lot to do with C# not having separate objects for
DateTime, so that's where the need for Hungarian comes from)