You create an abstract class for Ajax actions. Different Ajax actions will all extend this class.
- Do you name the class AjaxAction or AbstractAjaxAction?
- When you create subclasses, do you name them:
- Just name them what they are
I have not been able to find what the "official" convention is. I don't see a need for the "Abstract" prefix or any required naming convention in the subclasses. (It may fit anyway, depending.)
Is there an official convention? Could you link me to it? And what are your opinions on this subject?