I often see code that include intentional misspellings of common words that for better or worse have become reserved words:
Class clazz = ThisClass.class
kountfor count in SQL:
count(*) AS kount
Personally I find this decreases readability. In my own practice I haven't found too many cases where a better name couldn't have been used —
However, it's so common that I can't help but wonder if I'm the only one? Anyone have any advice or even better, quoted recommendations from well-respected programmers on this practice?