Take the 2-minute tour ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

Should I develop on the latest and greatest 1.7 version of Joomla or stick with the well documented version of 1.5?

I'm new to Joomla (and webDev in general), so I bumble around, search online, and ask those wiser then myself. The problem is that the answers are for version 1.5, and don't apply to 1.7, so I'm floundering.

Usually I'd go with using the latest and greatest.

  • It should be supported longer
  • It should have bug fixes
  • New awesome things will be developed won't be backwards compatible
  • The extensions and components for the old version won't be maintained

But I need to crank this site out in a month. And if I'm fighting bad or lacking documentation, it's going to be an uphill battle.

So, stick with the latest and greatest or go install what all the tutorials, guides, and videos are geared towards?

share|improve this question
    
Joomla have pretty good support, as long as you have selected that as part of your package. E-mail them with your questions. –  Darren Young Jul 28 '11 at 21:43
    
Package? It's free, baby! Dunno if the boss would spring for paid support, but it's certainly an idea. –  Philip Jul 28 '11 at 22:04
    
Hi Philip, your question, as it pertains to Joomla!, is pretty localized, but there's a general question about frameworks/software in there that's pretty interesting, so I've generalized your question a bit. However, while you've presented a pretty intuitive argument for why you wouldn't go with the latest and greatest, it's not clear why you would (and thus, it's unclear why you're asking this question). Can you expand upon your reasons why you're considering using the latest and greatest? –  user8 Jul 28 '11 at 22:58
    
@Mark, yes, there is a generalized question in there isn't there? I also had a good example of where the generalized question could be put to use. Thank you for your help, but you went a bit overboard. Thanks for the reminder to be explicit about the alternative. –  Philip Jul 29 '11 at 14:16
add comment

3 Answers

up vote 3 down vote accepted

If there is no compelling reason to use the latest major release (i.e. a must have feature, a must have with no work around bug fix) it is more economical to stick to a well proven version that been around for a while. My rule of thumb is double the effort required when using a Beta version of software. Some software is "released" in Beta form, so unless you know they have a good record, assume anything less than a few months is still Beta.

What I also find is that recent, but not the newest, software has more relevant information on the web. The newest makes lots of noise at a superficial level, but it takes months or even years to get down to all the nuts and bolts. It's easier to find answers to those particularly hard problems when the software been around a while and someone else has been there before you.

We don't call new releases bleeding edge for nothing.

share|improve this answer
    
Yep, can always upgrade down the road if a feature in a newer version presents itself and is a "must have". –  Chris Jul 28 '11 at 23:43
    
I wouldn't rush to use a new version of anything in production, especially if there's a learning curve, just for the sake of using the latest. That's what pilot projects are for. –  TMN Jul 29 '11 at 16:36
add comment
  • At work, develop with well documented versions of anything. This will let you focus on domain issues. You will also get faster and better results.
  • At home, fight against the latest and greatest. This will let you gain non-working but very valuable experience with new tools. You will also get deeper insights and new ideas.
share|improve this answer
add comment

I have had to ask myself this very same question only a few days ago to create a site that has to ship in a similar timeframe and I just had to go with 1.5, not just because of the core features but because of the components/modules that are supported in 1.5 and currently not supported in later versions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.