I have a bad habit of not properly naming my variables, I will often use just the letters ABC and add a number to the letter making it a1 or b2 this is making debuging more difficult, when i ask a ...
Often when the syntax of the language requires me to name a variable that is never used, I'll name it _. In my mind, this reduces clutter and lets me focus on the meaningful variables in the code. I ...
I often see code that include intentional misspellings of common words that for better or worse have become reserved words: klass or clazz for class: Class clazz = ThisClass.class kount for count in ...