New answers tagged

0

As far as "best practices" goes, I think it's a good idea to use a naming convention for methods that return "resource streams". If a stream has to be close()ed, call the factory method open() or openStream(). Call methods that construct ephemeral streams stream(), following the convention established by the SDK. Always put javadoc on the method to alert ...



Top 50 recent answers are included