4,800 reputation
1744
bio website staugustinefootville.org
location United States
age 30
visits member for 4 years, 7 months
seen Apr 30 at 0:15

Faithful Catholic - Father of 4, Husband of 1

Programmer of cloudish things from Southern Wisconsin.

Fairly proud Herzing, UW Madison and UW Rock County Alum


May
30
comment User defined type for healthcare / Medical Records variable name prefixes?
I'm not talking about using abbreviations for entire variables I'm talking about using abbreviations for prefixes of variable names like medPRN instead of medicationPRN. But yeah it's safer and cleaner, but it also can get substantially above 20 characters, where apparently productivity is diminished.
May
30
comment User defined type for healthcare / Medical Records variable name prefixes?
That's good advice, but I'd like an answer, not a generic suggestion. Also, their abbreviations are either morbidly terse or just plain old Latin. Hence PRN means as needed, and BID means twice a day.
May
30
comment User defined type for healthcare / Medical Records variable name prefixes?
It's in Code Complete in the variable naming section, I don't know a lot more than that. The author just gave an example of using ch for Character and pp for Paragraph, etc.. when naming variables when writing a word processor.
May
30
reviewed Reject What is a widely accepted term for a string variable that would probably contain a file path and file name?
May
30
comment User defined type for healthcare / Medical Records variable name prefixes?
Chart was probably a bad example since it's a pretty concrete object and I'd probably go with what you've got there, but medications and individual chart entries could behave more like character and paragraphs in word processors and might benefit from User Defined Types.
May
30
asked User defined type for healthcare / Medical Records variable name prefixes?
May
30
revised What is a widely accepted term for a string variable that would probably contain a file path and file name?
added 214 characters in body
May
30
comment What is a widely accepted term for a string variable that would probably contain a file path and file name?
@ErikReppen Yeah, I'm not concerned about convention, only usability. What I've got is not useable and prone to bugs. It seems like we should never, ever have a variable called "FilePath"
May
30
comment What is a widely accepted term for a string variable that would probably contain a file path and file name?
I wouldn't call it that because I don't ever want a directory name, I always want a file name.
May
30
asked What is a widely accepted term for a string variable that would probably contain a file path and file name?
Apr
4
awarded  Popular Question
Mar
26
revised Delivery terminology and order of magnitude
edited tags
Mar
26
revised Delivery terminology and order of magnitude
rolled back to a previous revision
Mar
13
comment Converting mysql and SQLServer tables quickly in an update utility
That's just a good idea. The second part I can't do. I think we could do the first. The only problem is we've got to unpack something we can only figure out with recursive queries. But I think the utility would still be fast - especially if all the blob moving is done in a insert into ... select statement.
Mar
13
asked Converting mysql and SQLServer tables quickly in an update utility
Feb
29
comment PDF help in the software manual
@GrandmasterB I'm not entirely certain any more why we don't use it as the main viewer (that's sort a recent topic of conversation between me and the guy who handed off the project to me). We avoided embedding the activex control until recently - the fallback reader is QuickPDF and it works just as well (we use it for generating the PDFs in the first place).
Feb
29
comment PDF help in the software manual
Nurses are my end users, nurses are my testers. I'm not knocking nurses and neither should you, but yes this is a serious consideration for them and yes, in my opinion, Adobe does drastically change the look and feel of their reader between major versions.
Feb
29
asked PDF help in the software manual
Feb
10
comment Is it a good practice to name the returned variable “result”?
Do you work with a lot of former Delphi programmers?
Feb
6
awarded  Popular Question