109 reputation
6
bio website
location New York, NY
age
visits member for 3 years, 4 months
seen Aug 27 at 14:55

Aug
19
awarded  Citizen Patrol
Jul
26
awarded  Nice Question
Mar
8
awarded  Editor
Mar
8
comment When checking for transposed day and month values between two Dates - should comparing 11/11/2000 and 11/11/2000 return true or false?
I understand your point in terms of absolute correctness. But I would feel compelled to lose the 'is' in the method name and call it something calcTransposeState(date1, date2). Thoughts on an alternate method name? Any isXYZ method that did not return true or false would be bad design in my opinion - sort of like isEmpty(null) returns true.
Mar
8
comment When checking for transposed day and month values between two Dates - should comparing 11/11/2000 and 11/11/2000 return true or false?
So we can't get a code review on an interface definition?
Mar
8
asked When checking for transposed day and month values between two Dates - should comparing 11/11/2000 and 11/11/2000 return true or false?
Dec
12
awarded  Supporter
Sep
28
awarded  Student
Aug
7
awarded  Teacher