101 reputation
1
bio website
location
age
visits member for 3 years, 1 month
seen Apr 18 at 13:20

Feb
10
comment Is it a good practice to name the returned variable “result”?
@Andy I see your point, but in reality, I can't imagine writing a function like that. If that's the reason for writing a function like that, it sounds like it should be broken down into smaller more understandable functions.
Feb
10
comment Is it a good practice to name the returned variable “result”?
Uhm, surely the fact that it'll say 'return' before it's returned is explicit enough? You should describe what you'll do with it, now the 'how'. Why not call it total, result, or something else descriptive of the purpose, then your code will ready "return total" or similar...
Dec
22
comment Form screenshot for legal proof of clicking one of the checkboxes?
"in a folder that isn't easily found" - aah, Security through obscurity! That's way more secure than a database kept on a secure server, requiring login credentials etc to get to...
Oct
1
comment Should you write good documentation and clean code to increase the “Bus Factor”?
You never want to be irreplaceable - how do you get promotion if you can't be replaced? Unless you're happy exactly where you are, forever, the 'Bus Factor' is always important.
Sep
6
awarded  Supporter