113 reputation
bio website
location Hell
visits member for 3 years, 8 months
seen 2 days ago

If apple pies were people, people would be lemons.
Have a tasty afternoon! :3

(I honestly don't know)

Previous Name: Ken
Email: pokiaka@gmail.com
Skype: pokiaka

comment What's the proper term for a function inverse to a constructor - to unwrap a value from a data type?
It is indeed called deconstruction in the Haskell circles. If it sounds odd, keep in mind that Haskell has no objects - just values; So it goes without saying that the term has a different meaning. The great part is that 'deconstruction' is exactly what it does. On that note I personally think object deconstructors should be called something along the lines of object disposers. It is much, much more accurate.
comment Is hungarian notation a workaround for languages with insufficiently-expressive (i.e. Haskell-style) static typing?
In Haskell you can quite easily get name clashes btw.
comment Why does Java have a “bad rap”
I think Java does have an exception with how much people don't like it. I don't think they hate the language so much, just the implementation, and I'm right there with them. And it's not just for that reason I don't program in it, it's also for that reason I don't let Java applications even reside in my computer, they're so horribly slow.
comment Is the use of “utf8=✓” preferable to “utf8=true”?
@jah Nope.
comment When to favor ASP.NET WebForms over MVC
I'm not one to speak so this is just my opinion. After reading most of the answers I came to conclusion that the answer is just never. MVC is just awesome and the only drawback I found is that I keep seeing ; at my webpage (If you're just beginning with Razor you'll get the joke).
comment Monitor screen size and programming ease
"I generally keep my IDE maximized in the big monitor, and run my code in the original one." Wonderful advice! I'm going to try it myself ;) Thank you Dylan!
comment When decomposing a large function, how can I avoid the complexity from the extra subfunctions?
Can you use a class that has a public function do_lots_of_stuff and private functions: subpart_1 subpart_2 etc.?
comment Should you sacrifice code readability with how efficient code is?
Because the reference you gave to a book, I'd like to add that I also found that in the early pages of Programming Principles and Practices using C++, Bjarne Stroustrup also mentions that code readability is an important key. it seems to be a very big deal.
comment I can't really create anything, what can I do about it?
Thank you, I did assume this has to do something with P/Invoke, now I know for sure. :)