Reputation
Top tag
Next privilege 125 Rep.
Vote down
Badges
4
Impact
~379 people reached

  • 0 posts edited
  • 1 helpful flag
  • 14 votes cast
Apr
13
awarded  Citizen Patrol
Apr
8
comment What is “Soft Coding”, really?
Don't code preemptively if you are not 80%+ sure that future will happen, and by the time you finished the future analysis to reach that 80%+ figure you usually used up more time that what would be needed to refactor the present-adjusted code. YAGNI indeed. +1'd (p.s.: 80% is a madeup number. Usually 90% of those random statistics are madeup anyway).
Mar
11
awarded  Commentator
Mar
11
comment Why have private fields, isn't protected enough?
@Broken_Window In my mind that part was read in the voice of Douglas Adams (with bonus side remarks in HHGttG style).
Mar
11
comment Is a big boolean expression more readable than the same expression broken down into predicate methods?
@Ajedi32 one doesn't have to write an essay on what the method does on the method name, or to have gramatically sound method names. If one keeps the abbreviation standards clear (across the work group or organization) won't be a problem with short names and readability.
Mar
10
comment Is a big boolean expression more readable than the same expression broken down into predicate methods?
And please, make them (method names) significative and short. 20+ chars method names sore my eyes. MatchesDefinitionId() is borderline.
Nov
10
comment Using compound statements (“{” … “}” blocks) to enforce variable locality
@Joe have to disagree. It is not tagged OOP, and it begins with "C-like". The fact is that a question tagged [carnivors] that mentions dogs does not immediately excludes felines or make it a dog question. Also the word method does not appear on the question body, just function. So it does not mention methods.
Nov
10
comment Using compound statements (“{” … “}” blocks) to enforce variable locality
@Joe the discussion in this comment thread was drifting too much into OOP.
Nov
10
comment Using compound statements (“{” … “}” blocks) to enforce variable locality
@Joe isn't the question language-independent. OP only mentions "C-like", every language that can have anonymous code blocks defining variable scope falls under this question.
Nov
10
comment Two structs with the same members but different naming, is it a good idea?
It is even more important if the OP is making classes out of those structs, since the operations on cartesian and polar coordinates are different.
Feb
26
comment Is it premature optimization to add database indices?
@MathematicalOrchid should've been an answer. Could run for "smallest-straight-to-the-point" answer ever.
Feb
24
awarded  Student
Feb
23
comment Caveats of using String.hashCode() on a switch on java < 1.7
@MichaelT isn't there a contract on the hashCode function documentation to always be that s[0]*31^(n-1) ... formula?
Feb
23
asked Caveats of using String.hashCode() on a switch on java < 1.7
Jan
16
comment Is there any material difference between queries joined by WHERE clauses, and queries using an actual JOIN?
I'd like to point the conflicting signals of a work with "the Hard Way" in the title skipping a concept "because they are insanely confusing". But maybe just my concept of what "the hard way" should be is wrong. But again, maybe not.
Sep
3
awarded  Supporter